RubyGems Navigation menu

saml2 3.0.9

The saml2 library is yet another SAML library for Ruby, with an emphasis on _not_ re-implementing XML, especially XML Security, _not_ parsing via Regex or generating XML by string concatenation, _not_ serializing/re-parsing multiple times just to get it into the correct format to sign or validate. For now, it provides a clean interface for implementing an IdP, but not an SP.

Versions:

  1. 3.0.9 - August 21, 2020 (92 KB)
  2. 3.0.8 - July 30, 2019 (90.5 KB)
  3. 3.0.7 - April 17, 2019 (90.5 KB)
  4. 3.0.6 - April 16, 2019 (90 KB)
  5. 3.0.5 - January 14, 2019 (88 KB)
Show all versions (43 total)

Runtime Dependencies (3):

  • activesupport >= 3.2, < 6.1
  • nokogiri >= 1.5.8, < 1.11
  • nokogiri-xmlsec-instructure ~> 0.9, >= 0.9.5
  • Development Dependencies (3):

  • byebug ~> 10.0
  • rake ~> 12.0
  • rspec ~> 3.5
  • Owners:

    Pushed by:

    Authors:

    • Cody Cutrer

    SHA 256 checksum:

    ece51362a93d3d32ef623207ded85de42490caebd7d2709d14308265b3f01152

    Total downloads 652,929

    For this version 1,825

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 0

    Links: