RubyGems Navigation menu

ruby_rabbitmq_janus 4.0.1

This gem is used to communicate to a server Janus through RabbitMQ software (Message-oriented middleware). It waiting a messages to Rails API who send to RabbitMQ server in a queue for janus server. Janus processes a message and send to RabbitMQ server in a queue for gem. Once the received message is decoded and returned through the Rails API.

Versions:

  1. 4.0.1 - September 23, 2021 (95.5 KB)
  2. 4.0.1.pre.1265973744 - September 23, 2021 (95.5 KB)
  3. 4.0.1.pre.1265506307 - September 23, 2021 (95.5 KB)
  4. 4.0.1.pre.1265140558 - September 23, 2021 (95.5 KB)
  5. 4.0.0 - July 05, 2021 (95.5 KB)
Show all versions (172 total)

Runtime Dependencies (6):

  • activesupport ~> 6.1, >= 6.1.3.1
  • bunny ~> 2.19
  • key_path ~> 1.2
  • parallel ~> 1.20
  • semaphore ~> 0.0.1
  • thread ~> 0.2.2
  • Development Dependencies (22):

  • activerecord ~> 6.1, >= 6.1.3.1
  • aruba ~> 1.1
  • bigdecimal ~> 3.0, >= 3.0.2
  • database_cleaner-active_record ~> 2.0
  • database_cleaner-mongoid ~> 2.0, >= 2.0.1
  • factory_bot ~> 6.1
  • json-schema ~> 2.8, >= 2.8.1
  • json-schema-rspec ~> 0.0.4
  • mongoid ~> 7.2, >= 7.2.2
  • pry-byebug ~> 3.9
  • rails ~> 6.1, >= 6.1.3.1
  • rake ~> 13.0, >= 13.0.3
  • reek ~> 6.0, >= 6.0.4
  • remote_syslog_logger ~> 1.0, >= 1.0.4
  • rspec ~> 3.10
  • rubocop ~> 1.13
  • rubocop-performance ~> 1.11, >= 1.11.1
  • rubocop-rspec ~> 2.3
  • simplecov ~> 0.21.2
  • simplecov_json_formatter ~> 0.1.3
  • sqlite3 ~> 1.4, >= 1.4.2
  • yard ~> 0.9.26
  • Owners:

    Pushed by:

    Authors:

    • VAILLANT Jeremy

    SHA 256 checksum:

    2033eda7acebd7d6adfeffa05982809e63621196cc8b19f85417b79f7668c3d7

    Total downloads 116,379

    For this version 127

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 2.7.0

    Links: