RubyGems Navigation menu

ruby-jss 1.6.0b1

The ruby-jss gem provides native ruby access to the REST APIs of Jamf Pro, an enterprise/education tool for managing Apple devices, from jamf.com. The JSS module provides access to the 'Classic' API, while the Jamf module provides access to the more modern 'Jamf Pro' API. Jamf Pro objects are implemented as classes and, within each module, can interact with each other. The underlying data transfer using JSON or XML is handled automatically under the hood to allow simpler, intuitive automation of Jamf-related Tasks.

Versiones:

  1. 1.6.4 - October 04, 2021 (400 KB)
  2. 1.6.0 - May 24, 2021 (400 KB)
  3. 1.6.0b1 - May 07, 2021 (400 KB)
  4. 1.5.3 - December 28, 2020 (400 KB)
  5. 1.5.2 - December 22, 2020 (400 KB)
Mostrar todas las versiones (69 total)

dependencias de Runtime (6):

  • CFPropertyList ~> 3.0
  • faraday >= 1.0.0, <= 1.0.1
  • faraday_middleware >= 1.0.0, <= 1.0.1
  • immutable-struct >= 2.3.0, ~> 2.3
  • recursive-open-struct >= 1.1.0, ~> 1.1
  • ruby-mysql ~> 2.9, >= 2.9.12
  • Propietarios:

    Subida por:

    Autores:

    • Chris Lasell, Aurica Hayes

    SHA 256 checksum:

    09570d3c0df3c204c06728d948ff3b9b451aa526c4a12384a6d7091b354bc37a

    Total de descargas 230.079

    Para esta versión 710

    Gemfile:
    = Copiar al portapapeles ¡Copiado!

    instalar:
    =

    Licencia:

    Nonstandard

    Versión de Ruby requerida: >= 2.3.0

    Versión de Rubygems requerida: > 1.3.1

    Enlace: