RubyGems Navigation menu

ripl 0.6.4

ripl is a light, modular alternative to irb. Like irb, it loads ~/.irbrc, has autocompletion and keeps history in ~/.irb_history. Unlike irb, it is highly customizable via plugins and supports commands i.e. ripl-play. This customizability makes it easy to build custom shells (i.e. for a gem or application) and complex shells (i.e. for the web). In other words, ripl is also a shell framework. Works on ruby 1.8.7 and greater.

版本列表:

  1. 0.7.1 - May 23, 2014 (23.0 KB)
  2. 0.7.0 - June 21, 2012 (22.0 KB)
  3. 0.6.4 - March 20, 2012 (22.0 KB)
  4. 0.6.3 - March 10, 2012 (22.5 KB)
  5. 0.6.2 - February 12, 2012 (22.5 KB)
显示所有 (32 个版本)

Runtime 依赖关系 (1):

  • bond ~> 0.4.0
  • Development 依赖关系 (4):

  • bacon >= 1.1.0
  • bacon-bits >= 0
  • bacon-rr >= 0
  • rr >= 1.0.4
  • 所有者:

    作者:

    • Gabriel Horner

    SHA 256 checksum:

    c8c0042be725086fd1db70eb25b0aa37a7774f270bb56ef28d19e11043d91c54

    下载总次数 1,304,276

    这个版本 15,337

    Gemfile:
    = 复制到剪贴板 已复制

    安装:
    =

    许可:

    需要的 Ruby 版本:

    需要的 RubyGems 版本: >= 1.3.6

    相关链接: