RubyGems Navigation menu

rex-encoder 0.1.7

This library provides the basis for all of the polymorphic encoders that Metasploit uses for payload encoding. Encoders are used to try and create a version of a payload that is free of bad characters as defined by the exploit.

Gemfile:
= Copy to clipboard Copied!

install:
=

Versions:

  1. 0.1.7 - October 04, 2023 (40.5 KB)
  2. 0.1.6 - August 12, 2021 (40 KB)
  3. 0.1.5 - November 30, 2020 (40 KB)
  4. 0.1.4 - May 11, 2017 (40 KB)
  5. 0.1.3 - April 07, 2017 (40 KB)
Show all versions (8 total)

Runtime Dependencies (3):

metasm >= 0
rex-arch >= 0
rex-text >= 0

Development Dependencies (2):

rake >= 0
rspec >= 0

Owners:

Pushed by:

Authors:

  • Metasploit Hackers

SHA 256 checksum:

1a8b7927b43d616c778621de572007cac752a332be926037010e574578ed97e6

Signature validity period:

October 07, 2020 - November 06, 2023 (expired)

Total downloads 2,315,744

For this version 74,047

Licenses:

N/A

Required Ruby Version: >= 2.2.0

Links: