RubyGems Navigation menu

rbx-require-relative 0.0.9

Ruby 1.9's require_relative for Rubinius and MRI 1.8. We also add abs_path which is like __FILE__ but __FILE__ can be fooled by a sneaky "chdir" while abs_path can't. If you are running on Ruby 1.9 or greater, require_relative is the pre-defined version. The benefit we provide in this situation by this package is the ability to write the same require_relative sequence in Rubinius 1.8 and Ruby 1.9.

Versiones:

  1. 0.0.9 - February 28, 2012 (9 KB)
  2. 0.0.7 - February 27, 2012 universal-ruby-1.8.7 (9 KB)
  3. 0.0.7 - February 27, 2012 universal-ruby-1.9.3 (9 KB)
  4. 0.0.7 - February 27, 2012 (9 KB)
  5. 0.0.7 - February 27, 2012 universal-rubinius-1.2 (9 KB)
Mostrar todas las versiones (19 total)

Propietarios:

Autores:

  • R. Bernstein

SHA 256 checksum:

002c8b49f02e8e682cf0817acc52150cee9ded3fb1968652570f882088983d9a

Total de descargas 1.340.269

Para esta versión 764.500

Gemfile:
= Copiar al portapapeles ¡Copiado!

instalar:
=

Licencias:

N/A

Versión de Ruby requerida: Ninguno

Enlace: