RubyGems Navigation menu

pg 0.19.1.pre20170124220800

Pg is the Ruby interface to the {PostgreSQL RDBMS}[http://www.postgresql.org/]. It works with {PostgreSQL 9.1 and later}[http://www.postgresql.org/support/versioning/]. A small example usage: #!/usr/bin/env ruby require 'pg' # Output a table of current connections to the DB conn = PG.connect( dbname: 'sales' ) conn.exec( "SELECT * FROM pg_stat_activity" ) do |result| puts " PID | User | Query" result.each do |row| puts " %7d | %-16s | %s " % row.values_at('procpid', 'usename', 'current_query') end end

Gemfile:
= クリップボードにコピー コピー完了!

インストール:
=

バージョン履歴:

  1. 1.5.6 - March 01, 2024 x64-mingw-ucrt (2.62MB)
  2. 1.5.6 - March 01, 2024 x64-mingw32 (2.76MB)
  3. 1.5.6 - March 01, 2024 x86-mingw32 (2.51MB)
  4. 1.5.6 - March 01, 2024 (216KB)
  5. 1.5.5 - February 15, 2024 x86-mingw32 (2.58MB)
  6. 0.19.1.pre20170124220800 - January 25, 2017 (224KB)
全てのバージョンを表示(全250件)

Development依存関係 (9):

hoe ~> 3.12
hoe-bundler ~> 1.0
hoe-deveiate ~> 0.8
hoe-highline ~> 0.2
hoe-mercurial ~> 1.4
rake-compiler ~> 1.0.3
rdoc ~> 4.0
rspec ~> 3.0

所有者:

作者:

  • Michael Granger, Lars Kanis

SHA 256チェックサム:

18bbe112a68f8c3b8f62f54e8e9efa3925b9ae32a6d3973734cd99fa4409a568

累計ダウンロード数 307,412,957

このバージョンのみ 2,906

ライセンス:

BSD-3-Clause

必要なRubyのバージョン: >= 2.0.0

必要なRubyGemsのバージョン: > 1.3.1

リンク: