RubyGems Navigation menu

marlowe 2.0

{Marlowe}[https://github.com/KineticCafe/marlowe] is a Rack middleware that extracts or creates a request ID using a pre-defined header, permitting request correlation across multiple services. When using Rails, Marlowe automatically adds itself to the middleware before <tt>Rails::Rack::Logger</tt>.

Versions:

  1. 2.0 - November 17, 2016 (12.5 KB)
  2. 1.0.3 - January 15, 2016 (9 KB)
  3. 1.0.2 - November 25, 2015 (8.5 KB)
  4. 1.0.1 - October 20, 2015 (7.5 KB)
  5. 1.0.0 - October 20, 2015 (7.5 KB)

Runtime Dependencies (2):

  • rack < 3, >= 0.9
  • request_store ~> 1.2
  • Development Dependencies (18):

    Owners:

    Authors:

    • Trevor Oke, Kinetic Cafe

    SHA 256 checksum:

    8636b3714188ae2246ea447fad9f88f842436f1dc78ce27252054db3296648c3

    Total downloads 35,110

    For this version 24,213

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: ~> 2.0

    Links: