RubyGems Navigation menu

logstash-mixin-deprecation_logger_support 1.0.0-java

This gem is meant to be a dependency of any Logstash plugin that wishes to use the Deprecation Logger introduced in 7.6 while maintaining backward-compatibility with earlier Logstashes. When used on older Logstash versions, it provides an implementation of the deprecation logger that forwards deprecation messages to the normal logger at WARN-level with a `DEPRECATED` prefix.

Gemfile:
= Copy to clipboard Copied!

install:
=

Versions:

  1. 1.0.0 - January 14, 2020 java (7.5 KB)

Runtime Dependencies (1):

logstash-core >= 5.0.0

Development Dependencies (1):

rspec ~> 3.9

Owners:

Pushed by:

Authors:

  • Elastic

SHA 256 checksum:

0bd7398564197daf15b5bc853370d52437789b0ae51a9b00b810c8ee3848111d

Total downloads 1,266,288

For this version 1,266,288

License:

Apache-2.0

Required Ruby Version: >= 0

Links: