RubyGems Navigation menu

license_finder 6.12.2

LicenseFinder works with your package managers to find dependencies, detect the licenses of the packages in them, compare those licenses against a user-defined list of permitted licenses, and give you an actionable exception report.

Versions:

  1. 6.12.2 - April 14, 2021 (154 KB)
  2. 6.12.1 - April 12, 2021 (154 KB)
  3. 6.12.0 - March 05, 2021 (154 KB)
  4. 6.11.0 - March 04, 2021 (153 KB)
  5. 6.10.1 - January 08, 2021 (153 KB)
Show all versions (123 total)

Runtime Dependencies (6):

  • bundler >= 0
  • rubyzip >= 1, < 3
  • thor ~> 1.0.1
  • tomlrb >= 1.3, < 2.1
  • with_env = 1.1.0
  • xml-simple ~> 1.1.5
  • Development Dependencies (14):

  • addressable = 2.7.0
  • capybara ~> 3.15.0
  • fakefs ~> 1.2.0
  • mime-types = 3.3.1
  • nokogiri ~> 1.10
  • pry ~> 0.14.0
  • rack ~> 2.2.2
  • rack-test ~> 1.1.0, > 0.7
  • rake ~> 13.0.1
  • rspec ~> 3
  • rspec-its ~> 1.3.0
  • rubocop ~> 0.81.0
  • rubocop-performance ~> 1.5.0
  • webmock ~> 3.5
  • Owners:

    Pushed by:

    Authors:

    • Ryan Collins, Daniil Kouznetsov, Andy Shen, Shane Lattanzio, Li Sheng Tai, Vlad vassilovski, Jacob Maine, Matthew Kane Parker, Ian Lesperance, David Edwards, Paul Meskers, Brent Wheeldon, Trevor John, David Tengdin, William Ramsey, David Dening, Geoff Pleiss, Mike Chinigo, Mike Dalessio, Jeff Jun

    SHA 256 checksum:

    122ec9063b9a2f9ebfa46eef04d2c0f2d6b7574b7c909ed6ddf3748c3dee5989

    Total downloads 12,098,115

    For this version 3,279

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 2.3.3

    Links: