RubyGems Navigation menu

kinetic_cafe_error 1.12

kinetic_cafe_error provides an API-smart error base class and a DSL for defining errors. Under Rails, it also provides a controller concern (KineticCafe::ErrorHandler) that has a useful implementation of +rescue_from+ to handle KineticCafe::Error types. Exceptions in a hierarchy can be handled in a uniform manner, including getting an I18n translation message with parameters, standard status values, and meaningful JSON representations that can be used to establish a standard error representations across both clients and servers.

Versiones:

  1. 1.12 - May 27, 2016 (30 KB)
  2. 1.11 - May 24, 2016 (30 KB)
  3. 1.10 - March 25, 2016 (30 KB)
  4. 1.9 - November 30, 2015 (30 KB)
  5. 1.8.1 - October 26, 2015 (30 KB)
Mostrar todas las versiones (16 total)

Propietarios:

Autores:

  • Austin Ziegler, Jero Sutlovic, Ravi Desai

SHA 256 checksum:

7ada7de6d212f00a31f57d6936ed6fd4fd620d05117eff23dd742c7a6ce63026

Total de descargas 22.492

Para esta versión 3.375

Gemfile:
= Copiar al portapapeles ¡Copiado!

instalar:
=

Licencia:

MIT

Versión de Ruby requerida: ~> 2.1

Enlace: