RubyGems Navigation menu

graphql-docs 5.0.0

Library and CLI for generating a website from a GraphQL API's schema definition. With ERB templating support and a plethora of configuration options, you can customize the output to your needs. The library easily integrates with your Ruby deployment toolchain to ensure the docs for your API are up to date.

Gemfile:
= Copier Copié!

installation:
=

Versions:

  1. 5.0.0 - July 03, 2024 (1,32 Mo)
  2. 4.0.0 - January 26, 2023 (1,32 Mo)
  3. 3.0.1 - October 14, 2022 (1,31 Mo)
  4. 3.0.0 - March 23, 2022 (1,31 Mo)
  5. 2.1.0 - December 30, 2021 (1,31 Mo)
Voir toutes les versions (50)

Dépendances de Runtime (7):

commonmarker >= 0.23.6, ~> 0.23
escape_utils ~> 1.2
gemoji ~> 3.0
graphql ~> 2.0
html-pipeline >= 2.14.3, ~> 2.14
sass-embedded ~> 1.58

Dépendances de Development (8):

html-proofer ~> 3.4
minitest ~> 5.0
rake ~> 13.0
rubocop ~> 1.37
webmock ~> 2.3
webrick ~> 1.7

Propriétaires:

Pushed by:

Auteurs:

  • Brett Chalupa, Garen Torikian

Total de contrôle SHA 256:

= Copier Copié!

Total de téléchargements 22 261 418

Pour cette version 184 256

License:

MIT

Version de Ruby requise: >= 3.1

Liens: