RubyGems Navigation menu

dimr 0.3.1

DIMr is a small extension to Jim Weirich's minimalistic dependency injection framework DIM. It allows easy dependency injection into ruby command classes.

Versions:

  1. 0.3.1 - May 08, 2017 (7 KB)
  2. 0.3.0 - May 03, 2017 (7 KB)
  3. 0.3.0.b - November 14, 2016 (7 KB)
  4. 0.3.0.a - November 11, 2016 (7 KB)
  5. 0.2.2 - August 10, 2016 (7 KB)
Show all versions (7 total)

Runtime Dependencies (1):

  • dim ~> 1.2
  • Development Dependencies (3):

  • bundler ~> 1.10
  • rake ~> 10.0
  • rspec >= 0
  • Owners:

    Authors:

    • Steve England

    SHA 256 checksum:

    f936f8a91f2bf2f1b1c7eaec91a9ba8c1ef8ce98a62d4438706f8cbc6764ac46

    Total downloads 20,527

    For this version 13,168

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 0

    Links: