RubyGems Navigation menu

derelict 0.6.2.travis.150

Provides a Ruby API to control Vagrant where Vagrant is installed via the Installer package on Mac OS X. Vagrant was historically available as a gem, naturally providing a Ruby API to control Vagrant in other Ruby libraries and applications. However, since version 1.1.0, Vagrant is distributed exclusively using an Installer package. To control Vagrant when it's installed this way, other Ruby libraries and applications typically need to invoke the Vagrant binary, which requires forking a new process and parsing its output using string manipulation.

バージョン履歴:

  1. 0.6.3.travis.153 - May 12, 2014 (33KB)
  2. 0.6.2 - May 12, 2014 (33KB)
  3. 0.6.2.travis.152 - May 12, 2014 (33KB)
  4. 0.6.2.travis.150 - May 12, 2014 (33KB)
  5. 0.6.1 - May 12, 2014 (33KB)
全てのバージョンを表示 (全84項目)

Runtime依存性 (3):

  • log4r != 1.1.11, ~> 1.1.0
  • memoist >= 0
  • open4 >= 0
  • Development依存性 (8):

    オーナー:

    作者:

    • Brad Feehan

    SHA 256チェックサム:

    83c081e70e2b37425178b0aa640d1d8d227d903c0d0ca70dbbed473a599d6ff6

    累計ダウンロード数 98,363

    現行バージョン 1,035

    Gemfile:
    = クリップボードにコピー コピー完了!

    インストール:
    =

    ライセンス:

    MIT

    必要Rubyバージョン: >= 0

    必要Gemバージョン: > 1.3.1

    リンク集: