RubyGems Navigation menu

colored2 2.0.2

This is a heavily modified fork of http://github.com/defunkt/colored gem, with many sensible pull requests combined. Since the authors of the original gem no longer support it, this might, perhaps, be considered a good alternative. Simple gem that adds various color methods to String class, and can be used as follows: require 'colored2' puts 'this is red'.red puts 'this is red with a yellow background'.red.on.yellow puts 'this is red with and italic'.red.italic puts 'this is green bold'.green.bold << ' and regular'.green puts 'this is really bold blue on white but reversed'.bold.blue.on.white.reversed puts 'this is regular, but '.red! << 'this is red '.yellow! << ' and yellow.'.clear! puts ('this is regular, but '.red! do 'this is red '.yellow! do ' and yellow.'.clear! end end)

Gemfile:
= 复制到剪贴板 已复制!

安装:
=

版本列表:

  1. 4.0.0 - August 24, 2023 (8.5 KB)
  2. 3.1.2 - February 14, 2017 (10.0 KB)
  3. 2.0.2 - March 10, 2016 (9.0 KB)
  4. 2.0.0 - March 10, 2016 (9.0 KB)
显示所有版本 (共 9 个)

Development 依赖 (3):

rake ~> 10.0
rspec ~> 3.4

业主:

作者:

  • Chris Wanstrath, Konstantin Gredeskoul

SHA 256 校验和:

98bf58202de6aa550a89e54189534cfc639a244c485f488240c3adf335c35603

下载总量 140,549,102

这个版本 4,522

许可:

MIT

需要的 Ruby 版本: >= 2.0.0

新的版本需要开启多因素验证: true

需要的 RubyGems 版本: >= 1.3.6

链接: