RubyGems Navigation menu

awestruct 0.6.1

Awestruct is a static site baking and publishing tool. It supports an extensive list of both templating and markup languages via Tilt (Haml, Slim, AsciiDoc, Markdown, Sass via Compass, etc), provides mobile-first layout and styling via Bootstrap or Foundation, offers a variety of deployment options (rsync, git, S3), handles site optimizations (minification, compression, cache busting), includes built-in extensions such as blog post management and is highly extensible.

Versions:

  1. 0.6.1 - May 23, 2020 (110 ko)
  2. 0.6.0 - February 20, 2020 (110 ko)
  3. 0.6.0.alpha4 - January 12, 2020 (110 ko)
  4. 0.6.0.alpha3 - August 19, 2019 (110 ko)
  5. 0.6.0.alpha1 - March 25, 2018 (109 ko)
Voir toutes les versions (91)

Dépendances de Runtime (13):

  • asciidoctor >= 1.5.2, < 3.0
  • git ~> 1.2, >= 1.2.6
  • guard ~> 2.0, >= 2.13.0
  • guard-livereload ~> 2.0, >= 2.1.2
  • haml >= 4.0.5, < 6.0
  • listen ~> 3.1
  • logging ~> 2.2
  • mime-types ~> 3.0
  • oga ~> 2.0
  • parallel ~> 1.0, > 1.1.1
  • rack ~> 2.0
  • rest-client ~> 2.0
  • tilt ~> 2.0, >= 2.0.1
  • Dépendances de Development (6):

  • bootstrap-sass >= 3.2.0.2
  • compass-960-plugin ~> 0.10, >= 0.10.4
  • guard-rspec >= 4.0
  • nokogiri >= 1.5.10
  • rspec >= 3.0
  • zurb-foundation >= 4.3.2
  • Dépendances:

    Any markup languages you are using and its dependencies. Haml and Markdown filters are touchy things. Redcarpet or Rdiscount work well if you're running on MRI. JRuby should be using haml 4.0.0+ with Kramdown. Compass and sass are no longer hard dependencies. You'll need too add them on your own should you want them. We also should be able to work with sassc.

    Propriétaires:

    Pushed by:

    Auteurs:

    • Bob McWhirter, Jason Porter, Lance Ball, Dan Allen, Torsten Curdt, other contributors

    Total de contrôle SHA 256:

    fe825caae15f473050c7be54cf081362a21b7f7e8f923d384c5e0c82c3457a4b

    Total de téléchargements 572 861

    Pour cette version 79 265

    Gemfile:
    = Copier Copié!

    installation:
    =

    License:

    MIT

    Version de Ruby requise: >= 2.4.0

    Liens: