RubyGems Navigation menu

abstractor 4.4.7

A Rails engine gem for deriving discrete data points from narrative text via natural language processing (NLP). The gem includes a user interface to present the abstracted data points for confirmation/revision by curator.

Versions:

  1. 4.4.7 - February 02, 2016 (26.1 MB)
  2. 4.4.6 - September 04, 2015 (26.1 MB)
  3. 4.4.5 - June 30, 2015 (26.1 MB)
  4. 4.4.4 - June 24, 2015 (26.1 MB)
  5. 4.4.3 - June 05, 2015 (26.1 MB)
Show all versions (45 total)

Runtime Dependencies (10):

  • coffee-rails >= 4.0.0, ~> 4.0
  • haml >= 4.0.5, ~> 4.0.5
  • httparty >= 0.13.3, ~> 0.13.0
  • jquery-rails >= 4.0.0, ~> 4.0.0
  • jquery-ui-rails >= 4.2.0, ~> 5.0
  • paper_trail >= 3.0.0, ~> 3.0.0
  • rails ~> 4.1
  • rubyzip >= 1.1.0, ~> 1.1.0
  • sass-rails >= 4.0.0
  • stanford-core-nlp-abstractor >= 0.5.3, ~> 0.5.3
  • Development Dependencies (12):

  • ansi >= 1.4.3, ~> 1.4.3
  • capybara >= 2.4.0, ~> 2.4.0
  • cucumber-rails >= 1.4.0, ~> 1.4.0
  • database_cleaner >= 1.3.0, ~> 1.3.0
  • factory_girl_rails >= 4.4.0, ~> 4.4.0
  • redcarpet >= 3.1.1, ~> 3.1.1
  • rspec-rails >= 3.0.0, ~> 3.0.0
  • selenium-webdriver >= 2.42.0, ~> 2.42.0
  • sprockets >= 2.12.1, ~> 2.12.1
  • sqlite3 >= 1.3.9, ~> 1.3.9
  • webmock >= 1.2.0, ~> 1.2
  • yard >= 0.8.7.3, ~> 0.8.7.3
  • Owners:

    Authors:

    • Michael Gurley, Yulia Bushmanova

    SHA 256 checksum:

    37539d9531c7bd5d5456818a08810984915c3e219cca09287568996ee13e7718

    Total downloads 131,398

    For this version 2,625

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 1.9.3

    Links: