RubyGems Navigation menu

truemail 1.5.0

Configurable framework agnostic plain Ruby email validator. Verify email via Regex, DNS and SMTP.

Versions:

  1. 2.6.2 - January 19, 2022 (39.5 KB)
  2. 2.6.1 - January 04, 2022 (39.5 KB)
  3. 2.6.0 - December 28, 2021 (39 KB)
  4. 2.5.4 - December 03, 2021 (40 KB)
  5. 2.5.3 - November 08, 2021 (40 KB)
  6. 1.5.0 - December 29, 2019 (30 KB)
Show all versions (64 total)

Runtime Dependencies (1):

  • simpleidn ~> 0.1.1
  • Development Dependencies (15):

  • bundler ~> 1.16
  • bundler-audit ~> 0.6.1
  • fasterer ~> 0.8.1
  • ffaker ~> 2.13
  • json_matchers ~> 0.11.1
  • overcommit ~> 0.52.0
  • pry-byebug ~> 3.7
  • rake ~> 13.0, >= 13.0.1
  • reek ~> 5.5
  • rspec ~> 3.9
  • rubocop ~> 0.78.0
  • rubocop-performance ~> 1.5, >= 1.5.2
  • rubocop-rspec ~> 1.37, >= 1.37.1
  • simplecov ~> 0.17.1
  • truemail-rspec ~> 0.1.1
  • Owners:

    Pushed by:

    Authors:

    • Vladislav Trotsenko

    SHA 256 checksum:

    0de5bff1a7d1a8c4e86ec302da6c87d1f72857f3b341339aa9c0237b3d05c73f

    Total downloads 275,515

    For this version 1,919

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 2.5.0

    Links: