RubyGems Navigation menu

rubocop 0.29.1

Automatic Ruby code style checking tool. Aims to enforce the community-driven Ruby Style Guide.

Versions:

  1. 1.44.1 - January 25, 2023 (577 ko)
  2. 1.44.0 - January 23, 2023 (577 ko)
  3. 1.43.0 - January 10, 2023 (575 ko)
  4. 1.42.0 - January 01, 2023 (574 ko)
  5. 1.41.1 - December 22, 2022 (571 ko)
  6. 0.29.1 - February 13, 2015 (937 ko)
Voir toutes les versions (229)

Dépendances de Runtime (5):

astrolabe ~> 1.3
parser < 3.0, >= 2.2.0.1
powerpack ~> 0.1
rainbow < 3.0, >= 1.99.1

Dépendances de Development (5):

bundler ~> 1.3
rake ~> 10.1
rspec ~> 3.1.0
simplecov ~> 0.7
yard ~> 0.8

Propriétaires:

Auteurs:

  • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

Total de contrôle SHA 256:

fdef20af47f52e8130d39665fb5770fdc7cb72d9c5a5ba56078e0fe2c325f50c

Total de téléchargements 292 424 597

Pour cette version 742 964

Gemfile:
= Copier Copié!

installation:
=

License:

MIT

Version de Ruby requise: >= 1.9.3

New versions require MFA: true

Liens: