RubyGems Navigation menu

rbx-require-relative 0.0.7-universal-ruby-1.9.3

Ruby 1.9's require_relative for Rubinius and MRI 1.8. We also add abs_path which is like __FILE__ but __FILE__ can be fooled by a sneaky "chdir" while abs_path can't. If you are running on Ruby 1.9 or greater, require_relative is the pre-defined version. The benefit we provide in this situation by this package is the ability to write the same require_relative sequence in Rubinius 1.8 and Ruby 1.9.

Versões:

  1. 0.0.9 - February 28, 2012 (8,5 KB)
  2. 0.0.7 - February 27, 2012 universal-ruby-1.9.3 (8,5 KB)
  3. 0.0.7 - February 27, 2012 universal-ruby-1.8.7 (8,5 KB)
  4. 0.0.7 - February 27, 2012 (8,5 KB)
  5. 0.0.7 - February 27, 2012 universal-rubinius-1.2 (8,5 KB)
Mostrar todas as versões (19)

Donos:

Autores:

  • R. Bernstein

SHA 256 checksum:

bf7e44399cba17f2c0ef7379620ec4f6ace1e0c99214ed718bdb48b5833b9850

Total de downloads 1.343.126

Desta versão 2.781

Gemfile:
= Copy to clipboard Copied!

instalar:
=

Licenças:

N/A

Versão Requerida do Ruby: ~> 1.9.3

Links: