RubyGems Navigation menu

rbx-require-relative 0.0.6-universal-ruby-1.8.7

Ruby 1.9's require_relative for Rubinius and MRI 1.8. We also add abs_path which is like __FILE__ but __FILE__ can be fooled by a sneaky "chdir" while abs_path can't. If you are running on Ruby 1.9 or greater, require_relative is the pre-defined version. The benefit we provide in this situation by this package is the ability to write the same require_relative sequence in Rubinius 1.8 and Ruby 1.9.

Versies:

  1. 0.0.9 - February 28, 2012 (8,5 KB)
  2. 0.0.7 - February 27, 2012 universal-ruby-1.8.7 (8,5 KB)
  3. 0.0.7 - February 27, 2012 universal-ruby-1.9.3 (8,5 KB)
  4. 0.0.7 - February 27, 2012 (8,5 KB)
  5. 0.0.7 - February 27, 2012 universal-rubinius-1.2 (8,5 KB)
  6. 0.0.6 - February 23, 2012 universal-ruby-1.8.7 (8,5 KB)
Toon alle versies (19 totaal)

Eigenaren:

Authors:

  • R. Bernstein

SHA 256 checksum:

50401fcb7b2f721b46c5e59b0575957bb5849fcc8cfa3486b67307a8232234eb

Total downloads 1.347.428

Voor deze versie 2.223

Gemfile:
= Copy to clipboard Copied!

Installeer:
=

Licenties:

N/A

Required Ruby Version: ~> 1.8.7

Links: