RubyGems Navigation menu

gtk_module 0.2.0

This library is called gtk_module. It extends the Gtk/Gdk part of ruby-gnome2. It also contains several add-on colours, in the file gtk_colours.rb These colours can be used like so: include Gtk::Colours MEDIUMAQUAMARINE The constants correspond to the "typical" html colours, just in an upcased variant, so we have things like SLATEBLUE PALEGREEN ORCHID and so on. The idea behind this library here is to make the ruby-gnome bindings more "ruby-like" rather than have them a 1:1 mapping. I also use some custom widgets. Last but not least, for some strange reason this project is quite popular (in regards to active downloads per release) - I am not entirely sure why, but perhaps there may be several ruby users interested in GUIs + ruby, such as gtk in general. I will try to improve the quality of this project over time, but it is a hobby project, and it is not one of my more important projects either; so please do not expect too much from this project. It has been primarily added to cover my use cases in regards to ruby-gtk, and it still (!) heavily focuses on gtk2 rather than gtk3 (even though gtk3 looks cleaner; I just did not have enough time to port all old ruby-gtk2 code to ruby-gtk3 yet). Thank you. IMPORTANT NOTICE: gtk_module is deprecated since as of January 2020. A new gem will be uploaded in due time, called gtk_paradise. This one will focus on gtk3 by default. Support for gtk2 will be retained, but not as the default. This was the only way for me to move forward, because I realized that I do not have enough time to update all my old legacy code to ruby-gtk3, so I simply started from scratch. This gem will be pulled once the transition is done.

Versions:

  1. 0.2.0 - January 15, 2020 (114 KB)
Show all versions (340 total)

Owners:

Pushed by:

Authors:

  • Robert A. Heiler

SHA 256 checksum:

30b1405dc650f30b67968032dbf1cdcd0397c42fed44dd43a0ae4a63dbabbb8e

Total downloads 118,223

For this version 104

Gemfile:
= Copy to clipboard Copied!

install:
=

License:

LGPL-2.1

Required Ruby Version: >= 2.7.0

Required Rubygems Version: >= 3.1.2

Links: