RubyGems Navigation menu

dry-schema 1.9.1

dry-schema provides a DSL for defining schemas with keys and rules that should be applied to values. It supports coercion, input sanitization, custom types and localized error messages (with or without I18n gem). It's also used as the schema engine in dry-validation.

Versions:

  1. 1.10.5 - September 21, 2022 (44.5 KB)
  2. 1.10.4 - September 13, 2022 (44.5 KB)
  3. 1.10.3 - September 10, 2022 (44 KB)
  4. 1.10.2 - August 23, 2022 (44.5 KB)
  5. 1.10.1 - August 22, 2022 (44 KB)
  6. 1.9.1 - February 17, 2022 (42.5 KB)
Show all versions (46 total)

Runtime Dependencies (6):

  • concurrent-ruby ~> 1.0
  • dry-configurable ~> 0.13, >= 0.13.0
  • dry-core ~> 0.5, >= 0.5
  • dry-initializer ~> 3.0
  • dry-logic ~> 1.0
  • dry-types ~> 1.5
  • Development Dependencies (3):

    Owners:

    Pushed by:

    Authors:

    • Piotr Solnica

    SHA 256 checksum:

    7d97907b05e2576674769f786f40f34e14cc12f2590285f702e5e2006914d990

    Total downloads 23,250,226

    For this version 1,401,140

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 2.7.0

    Links: