RubyGems Navigation menu

commander 4.5.0

The complete solution for Ruby command-line executables. Commander bridges the gap between other terminal related libraries you know and love (OptionParser, HighLine), while providing many new features, and an elegant API.

Versiones:

  1. 4.5.2 - March 12, 2020 (40 KB)
  2. 4.5.1 - March 08, 2020 (40 KB)
  3. 4.5.0 - January 21, 2020 (40 KB)
  4. 4.4.7 - October 22, 2018 (40 KB)
  5. 4.4.6 - August 01, 2018 (40 KB)
Mostrar todas las versiones (38 total)

dependencias de Runtime (1):

  • highline ~> 2.0.0
  • dependencias de Development (4):

  • rake >= 0
  • rspec ~> 3.2
  • rubocop ~> 0.49.1
  • simplecov >= 0
  • Propietarios:

    Subida por:

    Autores:

    • TJ Holowaychuk, Gabriel Gilder

    SHA 256 checksum:

    4bd30abd60d5b7008ed6a1f5d9e0afedf9e4fbff9329d253f41f93cc06a7b7f4

    Total de descargas 12.752.806

    Para esta versión 114.065

    Gemfile:
    = Copiar al portapapeles ¡Copiado!

    instalar:
    =

    Licencia:

    MIT

    Versión de Ruby requerida: >= 0

    Enlace: